Process delays on 3CX orders via FLUX
Incident Report for Destiny
Resolved
This incident has been resolved.
Posted Jul 16, 2020 - 14:35 CEST
Identified
Please be informed that 3CX orders in FLUX are queued and will be processed with a delay.
Posted Jul 16, 2020 - 10:44 CEST